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1 Overview

IPMI View (IPMI-Over-LAN) is a management software program based on the IPMI specification
Reversion 1.5 - 2.0. IPMI View sends IPMI messages to and from the BMC (Base Management Card) on a
host system at a remote location. IPMI messages are encapsulated in RMCP (Remote Management
Control Protocol) packets called “datagrams.” This method is also referred to as “IPMI-over-LAN.”

According to the Distributed Management Task Force (DMTF) specification, RMCP is used for system
management in a pre-0S or an 0S-absent environment. RMCP is a simple request-response protocol
that can be delivered using UDP (User Datagram Protocol) datagrams. IPMI-over-LAN uses version 1 of
the RMCP protocol and packet format. An RMCP packet is transmitted via an IP (Internet Protocol)
network, which allows system managers to manage their IPMI-enabled systems over the Internet. In a
private LAN network, this is a basic feature. IPMI uses the same UDP port number (623 in decimal) as
the ASF (Alert Standard Forum) protocol. If the managed system is protected by a firewall, UDP port 623
must be opened.

In Supermicro’s IPMI solution, a BMC (Baseboard Management Controller) shares the LAN1 NIC on the
mainboard. (If there are more than one LAN ports on the mainboard, LAN1 is the one closest to the
Keyboard/Mouse port.) The NIC will re-route the IPMI packet to the BMC instead of forwarding it to the
upper layer of the network protocol stacks as other protocol packets do.

IPMI View V2.0 covers Supermicro’s BMCs for both IPMI v1.5 and IPMI v2.0. However, due to design
changes, some functions may not be available for IPMI v1.5, while others might no longer be available
for IPMI v2.0. IPMI View will automatically hide any functions that are not available based on the BMC
version used in the system.
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2 System Management
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e Menu Bar: contains functions that allow you to add/delete systems or groups and save
configurations.

e Toolbar: contains functions that allow you to execute commands quickly. Click the icons on the
toolbar to add a new system, save the current configuration settings, to discover IPMI devices, to
access group management, to discontinue the IPMI View section and to access the help menus. See
Figure 2-2 for details.

e Logo: Click the Logo icon to visit Supermicro’s website.

e |PMI Sorting: This allows you to sort devices in ascending/descending order via the online format,
or in their original sequence.

e System List: This lists the computers managed by the BMC Controller.

e Group Management: This allows the user to manage system groups, including creating/adding new
accounts, deleting accounts and updating group information.

e Group List: This lists the computer groups managed by the BMC for better management.
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e Viewing Window: This shows detailed information including Login, IPMI Device, Event Log, Sensors,
BMC Settings, and the status of the IPMI View firmware.

e System View Sessions: IPMI View can manage up to 20 systems at any given time. The systems that
are currently managed by the BMC are indicated in the System View window.

e Bottom Toolbar: This toolbar contains function tabs that allow you to execute commands quickly.
The tabs allow you to access the following submenus: Login, Event Log, Sensors, IPMI Device, BMC

Setting, Users, Text Console, and KVM Console.

As shown in Figure 2-1, there are several components in the IPMI View window (Figure 2-2):

7 IPMI Yiew ¥2.6.29 (build 070927) - Super Micro Computer, Inc.
File Edit Manage Help

BE a/3d e R
SUPERMICR®

i IPMI Domain =~ & - § 7 &

;) 192.168.10 243

1PMI View

Intelligent Platform Management Interface

IPMI 2.0/1.5 over LAN

Ready

Figure 2-2

e ToolBar (Top)

The toolbar provides you with direct access to the features that are used frequently (as shown in Figure
2-3). You are able to switch between server- and group- management. The following toolbar shows the
items that are currently available for user configuration under BMC management.
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Figure 2-4

Click File> New> System to add a new system to the IPMI connection (as shown in Figure 2-4). An “Add
a new system...” dialog box will display as shown in Figure 2-5.
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& Add a new system. .. El |E| El

System Marme:

P address: | 0000 |

Descrigtion: | DESCRIFTION |

Figure 2-5

In the “Add a new system” dialog box, enter the System Name for the system to be managed by the
BMC, its IP address, and its description. Then click OK.

e Adding a new group

For better system management, the manager may group systems into different groups. A system may
be included in multiple groups. The default group is the “IPMI Domain.” All systems under BMC
management belong to the IPMI Domain even if they are also added to other groups.

Click the menu: File> New...> Group to add a new group to the IPMI connection.

An “Add a new group” dialog box will display as shown in Figure 2-6.

2 4dd a new ZTOnp

Group Mame;

Description: | DESCRIPTION |

Figure 2-6

In the “Add a new group” dialog box, enter the Group Name and its description. Then click OK.

e Discover IPMI Device

IPMI View offers a feature that will detect all devices or systems currently connected to the network.
The user may specify a Network IP address range and network Mask, then click Detect or Start to search
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for any IPMI devices or systems that are connected to the IPMI 1.5 or IPMI 2.0 connections as shown in
Figure 2-7. Click Exit to discontinue this process.
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Figure 2-7

e Reload Configuration

From the pull-down menu, click File> Reload Configuration to load the configuration settings that were
previously saved.

e Save Configuration

From the pull-down menu, click File> Save Configuration to save the current configuration settings.

e Update Firmware

From the pull-down menu, click File> Update Firmware, and select the system you wish to update from
the IPMI Domain list on the left side of the window. A Confirmation dialogue box will appear. Click OK to
update the IPMI Firmware. Click Cancel to discontinue this process.

From the pull-down menu, click File> Save Configuration to save the current IPMI View configuration
settings.

e Language

From the pull-down menu, click File> Language to activate a Language submenu. From the submenu,
you can select Chinese (Taiwan), Chinese (China) or English (USA) as your IPMI language setting.

e Exit

From the pull-down menu, click File> Exit or press <Alt-F4> to exit IPMI View.

Supermicro IPMI View User’s Guide _



e Modify System

Select a system in the System Window you want to modify and click Edit> Modify System to modify it
from the pull-down menu as shown in Figure 2-8.

You can also right click on a system in the System Window and select Modify in the pop-up menu to
modify it.

e Modify Group

Select a group in the Group Window you want to modify and click Edit> Modify...> Group from the pull-
down menu shown in Figure 2-8 to modify it.

You can also right-click a group in the Group Window and select Modify in the pop-up menu to modify

it.
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IPMI Security | Crowp | 3192168102
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Refresh

Timeout ...

192.168.10.242
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v 9 8%

Figure 2-8

e Delete System

Select a system in the System Window you want to delete and click Edit> Delete System from the pull-
down menu as shown in Figure 2-8 to delete it.

You can also right click on a system in the System Window, and select Delete in the pop-up menu to
delete it.
e Delete Group

Select a group in the System Window you want to delete and click Edit> Delete Group from the pull-
down menu to delete it as shown in Figure 2-8.

You can also right click a group in the System Window, and select Delete in the pop-up menu to delete
it.
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e IPMI Security

From the pull-down menu, click Edit> IPMI Security to activate the IPMI Security dialogue box. Check
Auto Detection for IPMI View to automatically check the current IPMI status. Check the For Advanced
User box to select the following protocols as shown in Figure 2-9.

Hardware: BMCB, Firmware:IPMI 1.5:
Hardware: BMC2, Firmware:IPMI 2.0 (non-RMCP+):
Hardware: BMC2, Firmware:IPMI 2.0 (Standard RMCP+).

Check the Encryptor box to use encryption supported by the IPMI 2.0 Standard RMCP+. All packets
transmitted from IPMI View to the BMC system management will be encrypted.

IPMI Protocol X
9 IPMI Protocol for Mew System
\_‘

() Auto Detection
Far Advanced User. Select Following Pratocol: bazed on Hw and P
() Hw' : BMCE, P/ IPMI 1.5
() How: BME2, Fvy: IPMI 2.0 non-RMCP+
(&) Hw': BMCZ, Pw/: IPMI 2.0 Standard RMCP+
Encryptior

Hiw' = Hardware
P = Firmnware
Figure 2-9

e Joinagroup

Select a group in the Group window, a system in the System Window, and click Edit> Join from the pull-
down menu to include (to join) this system into the group as shown in Figure 2-8.

¢ Disjoin a System or a Group

Double click the group from which you want to disjoin a system. The systems that are included in the
group will appear in the System Window. Then, select the system you want to disjoin from the group,
and click Edit> Disjoin from the pull-down menu shown in Figure 2-8. You can also select a group from
the Groups list and click Edit> Disjoin to remove it from the IPMI groups.

You can also right click the selected system, and select Disjoin in the pop-up menu to remove it from the

group.
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e Refresh

Double click the group from which you want to disjoin a system. The systems that are included in the
group will appear in the System Window. Select the system you want to refresh, and click Edit> Refresh
from the pull-down menu to refresh the system as shown in Figure 2-8.

e Timeout

The timeout setting is shown in Figure 2-10. Timeout is the period for IPMI View to wait for a response
after sending a command to a managed system. If a response is not received from the managed system
in the timeout period, IPMI View will resend the command to managed system again. You may specify
the timeout value (in seconds) to get a quicker response from the managed system. You can also specify
the number of times that IPMI View will resend the command.

Setting

Timeaut for retry [secondj 2 |

9
\-:‘/ Murnber of retry | 20 |

[0].4 Cancel

Figure 2-10

e Section

IPMI View will display the IP address(es) currently connected to the network when you click Section
from the toolbar. You can disconnect the IPMI connection from a system currently connected to the
network by clicking Closing. (the IP Address)”.
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Figure 2-11
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e IPMI View Management

IPMI View allows you to manage your server or your network group by selecting Manage> Server/Group
from the pull-down menu as shown in Figure 2-11.

In addition, you can also configure Group Login Settings by selecting Setting from a pull-down menu
under the Manage tab. A dialog box will appear, prompting you for the Login ID and Password. Once
enter the values in these fields, click OK to access the page and configure the settings. Please note that
this feature is available for the system administrator only.

e Help

Select About to display the information on the systems connected to the network.
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3 Login

e Login

Click the Login tab on the bottom toolbar as shown in Figure 3-1. A login screen along with some
information about the managed system will appear in the Viewing Window. Enter the login ID and
password, and click the Login button to log in. When login is successful, the connection information will
be shown at the bottom. The Login button is grayed (disabled), and the Logout button as well as other

available management functions will be enabled as shown in Figure 3-2.

Fle Edk Sesson Manage Help

il e @i RO

SUPERMICR® |~
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%;:2 :::: j,_; | SystemName 152168138
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), New System
5 o sptens Desciiplion DESCRIPTION
=, New Systemd
), New SystemS
LoginID | ADMIN
Password | ****~

save ID and Password

[Ready
Figure 3-1
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e Bl Tesmn Mamge Help

DEAADO RO

SUPERMICR® | ="
PMiDumen -~ v o B2 &
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T 102.160.10.243 IF Addrees 0902166 101341
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LopalD |ADMIN
o
[7) v 100 sod Pt
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.._ — CONNECTED
Groups Raa®
TFMI Domain (82}

Yernon - M1 20 RMCP
Ciphes e - RAKF-HMAC-SHAL, HMAC-SHAL-56, AE-CBC- 128

| Login | EventLog] Senson | TPM Device | BMC Sersg | Unn | Tesd Comoce | KVM Console | Virtosd Medin

RMCT Open Sermion racoesstel

Figure 3-2
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The default Login ID and password are “ADMIN”. Both are case-sensitive.

In IPMI View, an MD5 algorithm will encrypt the password when it is transmitted through the network.
(If you are connecting to the IPMI 2.0 RMCP+, all the data will be transmitted by an encrypted
algorithm.) Once the password is confirmed, IPMI View will show a CONNECTED symbol, and all
available function pages will be shown as in Figure 3-2. If the password is invalid, a message will be
displayed in the Status Area that reads, “Unable to activate a session, please check ID and Password.”

and a Break symbol will be shown (see Figure 3-3).

:j IPMI Yiew ¥2 629 (build 070927) - Super Micro Computer, Inc_

File Edit Sesdon Manage Help

0 agdleRo
SUPERMICR. 1 B 19216810201

IPMIDomain & w £ 4

Bystern Name 19216810241

IP Address 192.168.10.241

Description  192.168.10.241
LoginID | admin
Pazsunind
save 1D and Password
Login
BREAK
=5 Groups &%
g [FMI Domein (404)
Login
RAKP Message 2 ervor: Unanthorized name (status code = 0Dh)
Figure 3-3

In order to reduce overhead on the managed system, all pages will not be refreshed automatically. The

user must refresh the pages manually as needed.

After logging in, the IPMI View main window will display as shown in Figure 3-2. A tool bar will display on

the bottom of the screen for your convenience.
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e Bottom ToolBar

As shown in Figure 2-4 below, this toolbar contains function tabs to allow you to execute commands

quickly. The tabs allow you to access the following submenus: Login, Event Log, Sensors, IPMI Device,
BMC Setting, Users, Text Console, KVM Console.

Log
Event Log
Sensors

'P“|’” Device  pnic setting

|
Login | Event Log | Sensors|| IPM Device | BMC Setting|| Users|

Text Console | KvM Console|

Users

Text Console
KVM Console

Figure 3-4
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4 Event Log

After you have logged into a system, the screen as shown in Figure 4-1 will display. Click the Event Log
tab on the bottom toolbar to activate the Event Log screen as shown in Figure 4-2.

DT IPMI Vaew V2629 (sl (70927) - Super Mucan Cosputer, Lne
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2 v 10 o Boamword
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Cigher Snitn : RARF-HMAC-SHAT, EMAC-SHA] 56, ARE-CEC12
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Figure 4-1
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Figure 4-2
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System Event Log

(0]

(0}

© O O O o o

All: Click this radio button to select all events.

From...to: Click this radio box to select a portion of events.

Get: Click this tab to get the event logs.

Export: Click this tab to export event logs to a file.

Clear All Entries: Click this tab to clear all event log entries.

Current SEL Device Timestamp: This item displays the timestamp of the current SEL device.
Set Timestamp: Click this tab to set the timestamp for the system selected.

Refresh: Click this tab to refresh this page.
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5 Sensors

This feature displays the status of each sensor used to monitor system health as shown in Figure 5-1.
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Refreshing sensors' status completed

Figure 5-1

e Fans: This window displays fan status.

e Voltages: This window displays voltage readings for various devices.

e Temperatures: This window displays temperature readings for various devices.

e Sensors: This window displays the devices being monitored.

e PSU: This window includes three tabs: PMBus, FRU, BBP (Battery Backup Power). Click each tab to
view the information.

o Refresh Every X seconds: Enter the number of seconds for the system to refresh.

o Refresh Now: Click this button to refresh the Sensors page immediately.

e Save Layout: Click this button to save the current layout setting.

o Hide inactive item: Check this box to hide inactive items.

e Show History: Check this box to display the sensor records.
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5.1 Discharging Battery

1. The battery can be automatically or manually discharged. In the PSU dialog box (see Figure 5-1), click

the BBP tab.
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] ithow History

Login | Event Log | Sensors | [PM Device | BMC Setting | Users | Text Console | K¥M Cansole|

Refreshing sensors' status completed

Figure 5-2

2. Click the top right field BBP2. A dialog box appears.

3. Select Auto and type desired number of days for the battery to discharge automatically, or select

s - — B
Battery Discharge Setting - g

Discharge
@ User  (Will discharge immediatels)
L9  —
Figure 5-3

User to manually discharge the battery. Click Update to start.
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6 IPM Devices

Click the IPM Device tab of the IPMI View management session in the Viewing Window (shown in Figure
6-1) to display the information and functionality of the BMC firmware installed in the system.

7] IEMI View ¥2.9.18 (build 130410} - Super Micro Compauter, Inc. A=
File Edit Zession Manage Help

SUPERMICR® !

IPMI Domain P % Drevice Information
- Fimvre Revisian 105 BCPT Bystern Power State 20430 i
IPMI Revision 2.0

Cm

Graceful Power Control

Nzl S tielatynm

Chazsiz Power Control
=) 10.133.176.172

110133176152 = = . e
= L Eowerdvown N EOWERIRE I Eowereycle N IResel |
2 10.133.176.

110.133.176.1883
) 10.133.176.129
) 10.133.176.88

EJJ 10.122.176.160 EMC U LED Fan Zpeed Mode
21 10.133.176.107 (&) Standard () Optimal
= Cold Reset Blink UID LED TUpdate
101331601 — O Ful
10121760 e O Heavy 10
(=N
25 Groups B&ad Y

[ 1PMI Domsain (107..

Login | Event Log || Sensors| IPM Device | BMC Setting | Users || Text Console | KVM Consmole

(et ACPT Power State succeeded

Figure 6-1

e Device Information
This shows the revision levels of the BMC and IPMI firmware.

e ACPI System Power State
This shows the power state of the managed system. If the managed system is in a power-off state,
the green light will be off. It will be updated automatically every five seconds.

e Graceful Power Control (Administrator and Operator only)

Graceful shutdown will inform the OS running on the managed system to shutdown within a
specified time. When the OS running on the managed system receives a graceful shutdown request,
it will start to shutdown system. This behavior is via ACPIl by emulating a fatal over temperature.
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Graceful Shutdown: This feature has the same function as “shutdown” in the Windows. Using this
feature will cause the managed system to enter the S5 state.

Power On Icon: Click on the Power-On icon to power on or power off the device.

Chassis Power Control (Available for the Administrator and Operator only)

This feature is used to manually control the power state of the chassis of a managed system. When
the BMC receives the power control command from the chassis, it will have direct control over the
power button or the reset button of a system.

Power Down: This feature will power off a managed system as it would when the Power-Down
button of the chassis is pressed.

Power Up: This feature will turn on the power of a managed system as it would when the Power-
Up button of the chassis is pressed.

Power Cycle: This feature will turn off the power of a managed system for a few seconds and then
turn on the power of the system again.

Reset: This feature resets a managed system as it would when the Reset button of the chassis is
pressed.

BMC Cold Reset (for the Administrator only)

Clicking the Cold Reset button allows you to reset the BMC. After confirming the reset of the BMC,
the session will be terminated immediately. The user has to close this session manually. This feature
is rarely used. It is only used for an event when you suspect a system malfunction for example.

UID (Unit Identifier) LED

0 Blink UID LED: Click this table for the UID LED to blink when the unit in question is identified.
Refresh

Click this tab to refresh this page.

Fan Speed Mode

Select the desired fan speed mode and click Update. Note that available speed options vary.
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7 BMC Settings

(Available for the Administrator only)

Click the BMC Setting tab of the IPMI View management session in the Viewing Window (as shown in
Figure 7-1) to display detailed information on the BMC LAN Configuration, SNMP trap configuration and
the serial port status.

BWMC LAN Cenfiguration

e [ e | G
Subnet Mask l:l LAN MAC must be correct while update
AT 5] A e
SNMP
Comsy i
SNMF Trap Receivers IP dddress
0.0.0.0 S
0.0.0.0
0.0.0.0
0.0.0.0
0.0.0.0 B
L AN Interface
O Dedicated © On Board LAN1 () Failover

Figure 7-1

e BMC LAN Configuration

This feature displays the IP address, the LAN MAC, the Gateway IP, the Gateway MAC and the Subnet
Mask of the BMC and allows you to modify these settings. NOTE: please make sure that the MAC
address of the LAN and the gateway for the BMC are correct before updating it by clicking the <Update>
button. Be careful to enter the correct values especially for the LAN MAC. If you enter the wrong LAN

MAC, IPMI View will not be able to connect to that system any more.

If you accidentally enter a wrong LAN MAC value, you may use the IPnMAC.exe command in the IPMI

Solution/Utility subfolder on this CD to update it. To activate IPnMAC.exe., a DOS command, you must
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first boot your managed system to DOS, and then execute IPnMAC.exe on the managed system. You can
also enable the VLAN (Virtual LAN) Tag setting by clicking on the “Enable VLAN Tagging” box on the right
and enter the value on the VLAN Tag field to configure VLAN Tag setting.

e SNMP

This displays the SNMP trap configuration of the system that needs to receive the SNMP traps generated
by the BMC to allow you to modify the settings. To change the configuration on the BMC, enter the
SNMP community name in the Community text field, and enter the IP address as well as the MAC

address in the SNMP Trap Receivers table in the SNMP group. Then, click the Update button.

The SNMP Trap may have multiple destinations. When any critical error occurs, an SNMP trap packet
will be sent to all receivers in the list. To remove an SNMP receiver, you may change both IP and MAC

addresses to 0.0.0.0 and 00:00:00:00:00:00 respectively. Then, click Update.

For a system to receive the SNMP traps, you must install and run an SNMP trap receiver program. The
managed system will send out an SNMP trap packet to all receivers when an event occurs. If an SNMP
trap receiver is not running, the trap packet is discarded, and cannot be queued anywhere.
e RS232 / MODEM (available for IPMI 1.5 only)
This displays the configuration of the RS232 interface on the BMC. It is used to initialize the R$232 port
and the installed modem, if any. The RS232 port is the box-header (Figure 7-2) on the BMC, and a
dedicated serial port.

O Baud Rate: It is the baud rate for serial connections, which will not affect paging settings.

0 Modem Init String: This is the modem initialization string for serial link connections, which will

not affect paging settings.

Figure 7-2
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LAN Interface

0 Dedicated: Click this radio box to use the IPMI-Dedicated LAN as the default LAN connection.

O Onboard LAN1: Click this radio box to use the onboard LAN port 1 as the default LAN connection.
0 Failover: Click this radio box to enable Failover support.

0 Update: Click this tab to update LAN connection status.
(0]

Refresh: Click this tab to refresh the page.
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8 Users
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Figure 8-1 (For IPMI 2.0)
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Figure 8-2 (For IPMI 1.5)
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Click the Users tab of the IPMI View management session in the Viewing Window (as shown in Figure 8-

1 and 8-2) to display detailed information on the Users management, and paging severity thresholds for

IPMI 1.5.

We strongly recommend that you change the password immediately for security reasons.

e USERS

O User Name

IPMI View allows you to add or delete a user, to change a user’s password, to set and update user

privilege settings by clicking the appropriate tabs.

O Privilege

This feature allows you to set and update privilege level for a user or delete a user from the list.

There are six privilege levels, Callback, User, Operator, Administrator, OEM, and No Access. Only the

first four privileges are supported. Privilege Levels determine which IPMI commands a user can

execute over a channel. Privilege Limits set the maximum privilege level that a user is allowed to

operate at. A user is granted certain privileges for each channel, and the user can operate at a

privilege level that is granted. Click the “Update Privilege” to change the privilege level setting for a

user.

Group Privilege Levels

Callback This may be the lowest privilege level. Only those commands that are used
to initiate a Callback are allowed. (Available for IPMI 1.5 only.)

User Only the basic commands are allowed. These commands are used to read
and retrieve data, to modify BMC configuration settings, or to write data to
the BMC or other controllers. Actions such as resets, power on/off, and
watchdog activation are not allowed.

Operator All BMC commands are allowed, except for commands that can modify

out-of-band interface settings. For example, the Operator is not allowed to
disable individual channels or change a user’s access privileges.

Administrator

All BMC commands are allowed, including modifying commands. An
Administrator is allowed to execute configuration commands that disable
the channel over which the Administrator is communicating.

Supermicro IPMI View User’s Guide



O SOL (Serial-Over-LAN)
This feature allows the user to configure SOL settings. Click Enable to enable SOL support. Click
Update SOL Privilege to update a user’s SOL privilege level.
Click Paging Setting to set the parameters for an individual user (Figure 8-3). There are two
types of paging services: Numeric paging and alphanumeric paging. To use a paging service, a

modem must be connected to the RS232 connector on the BMC (Figure 7-2).

& Paging Sethng

User Mame | apping

Pager Mode

Paging Service Mumber 0912505132

Mumetic Meszage | SooERs

Moderm Init String | ATL1 W1 X355=2E

Dial String | ATDT

Update ” Cancel ][ Test Paging

Figure 8-3
e FRU (for IPMI 2.0 only)

This provides useful information on the board and the product, including the serial number, part
number, and the components of the motherboard. Click the Update FRU tab to update board
information and product information, including information on the manufacturer, the name of firmware,
the serial number/ the part number of the motherboard, and the part/model number of the BMC
firmware, the version and the serial of the IPMI/BMC firmware.

e PAGING/SEVERITY (for IPMI 1.5 only)

Use paging severity settings to determine when a user will be notified of an entry of the system event

log (SEL).

The following settings are available for each group:
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None When this setting is selected, user notification for this group is disabled.

Warning When this setting is selected, the RMC will notify the user when SEL entries

for the group exceed the warning thresholds.

Critical When this setting is selected, the RMC will notify the user when SEL entries

for the group exceed the critical thresholds.

All When this is selected, the RMC will notify the user of all entries of the SEL

events for the group.

All warning and critical thresholds are predefined by Supermicro based on hardware design.
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9 Text Console Redirection (SOL- Serial-
Over-LAN)

File Edit Session Manage Help

il aQABE ) R6e
| §192.153.1.38|

SUPERMICR® |

Power Status © (2) On @

M PMIDomain - - @ & %

Baud Rate [bps): .115200 Vi [CJUTF-8

Login|| EventLog| Sensors| IPM Device | BMC Setting | Users i

-@_et ACPI Power State succeeded

Figure 9-1

Click the Text Console tab on the bottom tool box (shown in Figure 9-1) to enable Text Console
Redirection support, which will allow you to control a remote system from a text mode console. Click
the Start button to start the text console redirection. Click the Stop button to stop the text console.

¢ BMCforIPMI 1.5
Console Redirection is not supported by the IPMI specification V1.5. Supermicro provides this useful
feature for a manager to control the managed system from a remote location. When a managed system

is booting up during the POST routine, and no other software application are available for you so that
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you can gain control over console redirection, IPMI View provides you with this valuable feature.
Console Redirection will redirect the monitor of a managed system for IPMI View use and allows you to

send the key codes to the managed system.

When a managed system changes its video mode from Text Mode to Graphics Mode, a termination
notice will be sent to IPMI View to terminate the console redirection. Text Console Redirection only

works with the text mode.

@ Important Note: Console Redirection can cast a very heavy load on a managed system. It

will redirect the whole monitor to the manager’s system, and it will slow down the managed
system significantly. We suggest that you use this function only when you absolutely need it.
For other applications, a proper console redirection software application (pcAnywhere,
Symantec Corporation) or a remote login protocol (telnet) is recommended. When you
finish your remote operation, click Stop to terminate console redirection to take the load off

the managed system.

* BMC for IPMI 2.0

Serial-Over-LAN (SOL) was designed to support Text Console Redirection based on the IPMI specification
V2.0. This function performs better in IPMI 2.0 than in IPMI 1.5. The Text mode console is supported by
the Windows 2003, even when the OS is running. To support Text Console Redirection on the Windows
2003, Special Administration Console (SAC) must be enabled. The following instructions are used to
enable the SAC:

1. Enable Console Redirection in the BIOS, and set it to COM 2 (or COM B)

2. Modify boot.iniin C:\. Boot.ini is a hidden file. An example of boot.ini is listed below.

[boot loader]

redirect=com2

redirectbaudrate=19200

timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]
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multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Standard" /fastdetect

/redirect
To enable Text Console Redirection support on a Linux Platform:

1. Host A with the IPMI BMC installed (for the Linux Platform):

a) BIOS POST:
(i) Enable "Console Redirection" in BIOS Setup.

For example, COM2 / 19.2Kbps / 8N1

(ii) Disable "Enable Console Redirection after POST" in the BIOS setup.

b) Boot Loader:
(i) For GRUB,
add the following TWO lines into /boot/grub/grub.conf, but
comment out "splashimage=(hd0,0)/grub/splash.xpm.gz"
serial --unit=1 --speed=19200 --word=8 --parity=no --stop=1
terminal --timeout=10 serial console

#splashimage=(hd0,0)/grub/splash.xpm.gz

(ii) Then add "serial console=ttyS$1,19200n8" to the end of kernel /vmlinuz in

/boot/grub/grub.conf.

For example:

kernel /vmlinuz-2.6.5-1.358smp ro root=LABEL=/ rhgb quiet serial console=tty51,19200n8

This will result in all boot messages being output to the console ttyS1, but you will not see

All these boot messages on the local console until the login message prompts.
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¢) LINUX OS:

(i) Add the following line into /etc/inittab.
s0:2345:respawn:/sbin/agetty ttyS1 19200

(ii) Edit /etc/securetty and add ttyS1

2. Host B with IPMI View installed:

a) Install and run IPMI View.
b) Log in Host A with the IPMI BMC installed as Admin.

c) Start Console Redirection in IPMI View immediately after the Host A reboots.

You will see the BIOS POST, the boot loader, and the Linux OS messages and prompts.
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10 KVM Console (KVM-Over-IP for Video
Redirection)

KVM Console Redirection is a new feature included in the Supermicro Intelligent Management (SIM)
Module. If Video Console Redirection support is enabled, the remote screen will be redirected to IPMI
View. BIOS POST, BIOS settings, DOS, Windows or Linux OS screens can all be redirected to IPMI View.

Click the Launch KVM Console tab to launch KVM console redirection.

Figure 10-1 shows sample screenshots of Video Console redirection. The screen of a remote managed
system will be redirected to IPMI View. You will see the screen of the remote system just as if you were

sitting in front of the system.
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Figure 10-1-1
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Toolbar
There are several tool buttons that can be used for video console as shown in Figure 10-2.

Zoom In
Select Percentage for Scaling Screen
Zoom Out

Send Ctrl+Alt+Del to Remote

Auto Adjust Screen
| 2 192168.10.249
[ c fes 100% - Ctrl+&t+Del lJ Opti|gr|3
Open or Close Quick Shot Panel Options

Quick Shot
Screen Capture

Full Screen

Stop Video Redirection

Start Video Redirection

Figure 10-2 Video Console Toolbar

I} Start Video Redirection:

This button is used to start video redirection. IPMI View will automatically start the video redirection

when you click the Video console tab.

0 Stop Video Redirection:

This button is used to stop video redirection. To stop video redirection, press this button again to stop it.

Please note that the drive redirection will continue to work when it is enabled.

Full Screen:

This button is used to maximize the size of the remote video screen on the local computer display. You

may press <Alt + Enter> to return to the original mode. Please refer to Figure 10-3.
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=l Screen Capture:
This button is used to capture the screenshots of the remote managed systems. You will see a file-save
dialog box with a preview image. Select the directory and filename to save it. The file format can be PNG

or JPG.

@ Quick Shot:
This button is used to capture quick screenshots. You will need to first specify a directory where you
want to store quick shot images. You will see the quick shot images in the quick shot panel. Please refer

to Figure 10-4.
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Open or Close a Quick Shot Panel:

This button is a switch used for opening or closing the quick shot panel. Double click the image in this

panel to show a full-size window for viewing.

@§ Zoom In:

This button is used for zooming in the screen (up to 300%). Please refer to Figure 10-5.
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®% Zoom Out:

This button is used for zooming out. The maximum zoom out percentage is 10%. Please refer to Figure
10-6.
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100% | select percentage for Scaling Screen:

This combo box allows you to select the setting of screen scaling, either 10%, 25%, 50%, 75%, 100%,
200%, 250% or 300%. An additional selection allows you to scale to fit with the IPMI View window size.

Crl+ 2 H+Del Send Ctrl + Alt + Del to Remote:

This button is used to send the <Ctrl + Alt + Del > key combination to the remote system. It is useful

when the remote system is running in the BIOS, DOS or Windows environment.

E‘ Auto Adjust Screen:

This button is used to adjust the screen automatically. Press this button if it’s difficult for you to see the

whole screen.

Option= .
F Options:

You can select more options here. The list of options is listed below.

*  Monitor Only: Use this feature to display the remote screen only. The keyboard and mouse will be
disabled.

* Readability Filter: This item uses algorithm to improve screen display. This will allow you to see the
text content easier when you scale the screen.

* Local Cursor: Use this to change local cursor settings.
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¢ Chat Window: This feature allows the user to chat with each other via the IPMI connection. Please

refer to Figure 10-7.

17 192.168.10.24 Chat 3

im@BM-LDCA410VIAD (super )=+ test
root@l inux{super == 456

Jim@IBM-DDCE4107030(super) | I Beep

Figure 10-7 Chat Window

Video Settings: This feature allows you to configure the advanced video settings. Please refer to

Figure 10-8.

Brightness ] _ | 70
ContrastRed | 1l | 114
Confrast Green _« | ] | 110
Contrast Blue  « | ] | 112

Clock 4 I | 1244
Phase x| I 29
Horizontal Offset _« | Il | 308
Vertical Offset  _« i | 34
Reset Al Modes |
Save Changes | 1,024x768 BOHz Undo Changes

Figure 10-8 Video Settings

* Refresh Video: This feature allows you to refresh the video screen.

Soft Keyboard: A virtual keyboard is provided for easy input. It also provides localized keyboard

mapping. Please refer to Figure 10-9.

English (Dnited States) 104pc X
E=z  F1F2F3|F4/F&FGF7FBFIF0F1F1Z Prh & | Brk
1zl 3l4l5|6|Flalalol-=l<In~|% & ]*
Eiqwert\,fuiop[](JDelEndI'\TI+
dlals(d flalh|j{k{T]|;]" |} +— a|+
iz ¥ v|binim|,|. 1] i T Ed+ |3
Crl | st it | Sthe ot [« [3|=+[ Ins De *

Figure 10-9 Soft Keyboard
* Local Keyboard: This feature allows you to set local keyboard mapping settings.
* Encoding: This feature supports encoding for the video screen. The options for encoding are

“Predefined”, “Compression” and “Color Depth”.
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Status Bar
Figure 10-10 displays the status bar for the video redirection.

Message Frames per second and In/Out bytes per second

4
Start Video redirection Fps: 20 In: 184 KB/s Out: 204 Bis i "]

Share Mode J Maonitor Mode

Figure 10-10

Start Video redirection
Message:

This section displays tool tip information and the video redirection status.

Fp=: 20 In: 124 KB/= Out: 204 B/s

This section indicates the number of the frames displayed per second, and Input (Kbytes per second)/
Output (bytes per second).
@ a
ad Share Mode:

This icon indicates the status of screen-sharing on the remote system. If there is only one user using the

]
video redirection of a remote system, the icon will look like _# | .If two or more users using the video

@ ']
redirection of the same remote system, the icon will look like ad

&4 Monitor Mode:

O
This icon displays the status of monitor mode. When the display looks like , it indicates that you

can use the local keyboard and the mouse to control the remote screen. When the display looks like

% , it indicates that the local keyboard and the mouse are not available. If you select the option

“monitor only”, the keyboard and mouse will be disabled.
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11 Virtual Media

The Supermicro Intelligent Management (SIM) Module provides a Virtual Media feature, which includes
a Virtual USB Floppy, a CD-ROM image and Drive Redirection.

Figure 11-1 shows the Virtual Media GUI. The Virtual Media Status section displays the current virtual
device status. There are two virtual drives available.

Floppy Image Upload allows the user to upload a floppy image as "floppy" located at the remote host.
The floppy image uploaded shall be in the binary format with a maximum size of 1.44MB. It will be
loaded to the Supermicro SIM card and emulated to the host as a USB device.

The CD-ROM Image on the “Windows Share” allows the user to configure Windows-Share settings. It
allows you to decide how you want to share the data stored in your shared folder with the users on the
remote host system.

Drive Redirection makes local drives accessible to other users via console redirection. This function
allows you to share your local drives (floppy, CD-ROM and HDDs) with users on remote systems.

[ 107 162 10 241
Yirtual Media Status
Dirive 1 Dirive 2
Type : Floppy image Empty

Read ! Write mode: Writable
File name : floppy.img (1474560 btes)

Floppy Linage Upload CD-ROM [mage on Windows Share
S D ] (5
Floppyr Image file: Shere host:
CMloppy.img Share name:
Path to image:
Upload floppy image done Tser (optional)

Paszword {optional):

Dirive: Redirection

Dirive 1: Not connected

Drive Redirection disconnected

Drive 2:| Connect Drive ][ Comnect 130 [Not connected

Drive Redirection disconnected

[(@miwi] ®

Login | Event Log | Sensors || IPM Device | BMC Setting | Users|| Text Console | E¥M Console | Virtnal Media

Figure 11-1
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Floppy Image Upload

As shown in Figure 11-2, click Open File to select the file that you wish to upload to a specific host drive
of your choice. Click Upload to upload the floppy image. Please wait for the uploading process to
complete. The virtual floppy will be activated after the floppy image is uploaded.

Flopgy Inage Upload
Dirivve:

Floppy Inage file:

Cifloppy img

Uploading floppy image

Figure 11-2
CD-ROM Image on Windows Share
Please refer to Figure 11-3 for the following items.
* Drive: Specify the drive that you want the remote host to share.
* Share Host: Enter the IP Address or the name of the system you wish to share data with via
“Windows Share”.
* Share Name: Enter the name of the shared data in the remote host.
* Path to Image: Enter the location of the source file that you wish to share via “Windows Share”.
* User/Password (Optional): Enter the user and password for the person to access the data that you

want to share, and click the Set button to enter your selections as shown in Figure 11-3.

CD-ROM Irnage on Windows Share

Drive: |2 =

Share host: 192165810117
Share narne: IS0
Path to itmage: CO =0

Uzer (optional):

Pazzword (optional):

Figure 11-3
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Drive Redirection

As shown in Figure 11-4, Drive Redirection supports both local drive and the ISO file. When you click the

Connect Drive button, a dialog will show up as figure 11-5.

* Local Drive List: This box displays a list of local drives available for remote access. Select from the list
a local drive that you want to make accessible for a remote server.

* Refresh List: Click this button to refresh the local drive list.

*  Write Support: Check this button to allow the remote operating system to have write access to the
drive that you have selected. This function allows a user to alter, overwrite, erase and destroy data
stored in the drive selected. This feature should only be used with non-critical data. Select the drive

and click OK to start direct redirection.

The second type of drive redirection is “Connect ISO”. You may redirect the ISO file directly from your
file system. Click this button and select an ISO file to start this function.

Dirive Redirection

Drivel:[ Connect Drive ” Comnect [30 ]Notconnected

Cancelled Drive redirection

Diive 2:[ Connect Drive ][ Comnect [30 ]Notconnected

Dirive Redirection disconnected

Figure 11-4
:j Select a drive to redirect @

v [ Refresh List ]

[ ] Enable Write support

| oK || Comcel |

Figure 11-5
Stop Active Drives

As shown in Figure 11-6, click Stop Drive 1 to disable Drive 1 and Click Stop Drive 2 to disable Drive 2.
The Refresh button is used for refreshing the Virtual Media settings. If you want to stop or change the
type of a virtual drive, you first need to stop it.

[ @stopDrive! | [ @ StopDrive | [ Refresh

Figure 11-6
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12 Group Management

Group management is a way to manage multiple servers at the same time. For example, you can query
the fan sensor readings from multiple servers and note their differences. Also, you can simultaneously
power on or off multiple servers at the same time. As shown in Figure 12-1, click <Manage Group> to
show group management. In group management, you can select multiple servers from the host group
on the left and manage them with the functions provided. You may re-arrange groups of servers in the
group list to make server group management easier.

7| IPMI Yiew ¥2.6.20 (build 070927) - Super Micro Computer, Inc.
File Edit 3Session B Help

B agde R
SUPERMICR@ (2 SoUP Managemment

AvQ &%

FﬁﬂlTempammm Voltage | Yensors| Event Log| ACFT| Power | LAN Config | FRU | Text Console | Greneral Info

omE

AN IPMI Domain

=] 19716810 343
m 192 16610 243

Srstern Nane g Sensor Name Reading Tnit Low Limit

=5 Groups E&d&d
IPMI Dormen (414)

] Refresh every seennds

Get Virtual Media information done

Figure 12-1

In the group management, a Login ID and password are required. Click Manage> Setting to set the login
information. Please note that IPMI View will use this account to login to multiple servers. (Figure 12-2)

Group Login Sething rz|

j ) LoginID ADMIN]
Y e

save [ and Pagsword
# Adminiztrator level iz required

Figure 12-2
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IPMI View provides various tools for group management. As shown in Figure 12-3, group management
can be grouped to the following categories.

* Fans

* Temperature

* Voltages

* Sensors

* Eventlog
* ACPI

* Power

* LAN Configuration
* FRU
* Text Console
* General Information
Group Management
Fan | Temperature | Yoltage | Sensors | Event Log | ACPI || Power | LAN Config | FRU | Text Conzole | General Info

Figure 12-3
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Fans

After you’ve selected multiple servers and clicked the <Fan> tab, a window will display as shown in
Figure 12-4. You can use <Ctrl+Click>, <Shift+Click> or draggin your mouse to select servers. Click the
Query button for IPMI View to collect the fan readings from the selected servers. The information listed
in the table shows the fan status of the selected servers. If a fan reading is colored in red, the fan may be
broken, not installed, or the reading is below the lower limit. When this occurs, the Administrator should
take precautionary measures to ensure that the system functions properly.

You may refresh the fan status by checking the Re-flash checkbox. IPMI View will refresh the fan status
based on a preset schedule. Please note that IPMI View will not refresh if you switch to another tab.

7] [PMI View ¥2.6.29 (build 070927) - Super Micro Compater, Inc. =13

File Edit Session Manage Help
BE a 800 2
SUPERMICR@ [ Srou» Mansgement
Fan|1'emperatu.re Voltage | Sensors | Event Log | ACPL | Power | LAN Config | FRU | Text Console | General Info
i IPMI Domain & - § £ & |
= ZmE
Fan
Sstemn Name 1P Sensor Name Reading it Low Limit
= 192.163.10.241 192.163.10.241 Fanl D REM 00
7] 19,163 10243 192.168.10.241 19216810380 [Fand 4700 RPM G|
192 168.10.241 192 168 10 241 Fan? i REM f00
192 168.10.241 192 168 10 241 [Fand i REM GO0
192 168.10.241 192 168 10 241 Fan’ i REM f00
192 168.10.241 192 168 10 241 [Fanfi i REM GO0
192 168.10.241 192 168 10 241 Fan?/CFU 1 i REM f00
192 168.10.241 192 168 10 241 Fan/CFT2 1200 REM GO0
192 168.10.131 192 168 10,131 Fanl i REM f00
192 168.10.131 192 168 10,131 [FanZ i REM GO0
192 168.10.131 192 168 10,131 Fan? 4800 REM f00
192 168.10.131 192 168 10,131 [Fand i REM GO0
192 168.10.131 192 168 10,131 Fan’ i REM f00
192 168.10.131 192 168 10,131 [Fanfi i REM GO0
192 168.10.131 192 168 10,131 Fan?/CFU 1 i REM f00
192 168.10.131 192 168 10,131 Fanf/CFT2 i REM GO0
25| Groups B&de
g IPMI Domain (5/5)
@B seoomds last updated 2007/0/01 15:53:06 (16)
Finish

Figure 12-4
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Temperatures

The screen shown in Figure 12-5 indicates that multiple servers have been selected, and the
Temperature tab is pressed. Clicking the Query button allows IPMI View to collect the temperature
readings from the selected servers. The information listed in the table shows the temperature settings
of the selected servers.

7] [PMI View ¥2.6.29 (build 070927) - Super Micro Compater, Inc. =13

File Edit Session Manage Help
BE e Od & S2
SUPERMICR@ 2 Sroup Mansgement
Fan Temperatu.re|vomge Sensors || Event Log | ACPI | Power | LAN Config | FRU | Text Console | General Info
M IPMIDomain =~ & ¥ o £ 0 M
Temperature
= Ls Sstemn Name 1P Sensor Name Reading it High Limit
= iéi:giggﬁ 192.168.10.241 19216810241 CPU Temp ] 35.0 dszee C 750
oA 102 168.10.241 192168 10,241 CPU Temp 2 530 degree C 750
192 168.10.241 192.168.10.241 CPU Temp 2 0o degres C 750
102 168.10.241 192168 10,241 CPU Temp 4 ] degree C 750
192 168.10.241 192.168.10.241 s Temp 320 degres C 750
102 168.10.131 192.168.10.131 CPU Temp 1 55.0 degree C 750
192 168.10.131 192.168.10.131 CPU Temp 2 0o degres C 750
102 168.10.131 192.168.10.131 s Temp 0.0 degree C 750
25| Groups E&de
[l IPMI Domain (5/5)
FlReeeren, seconds last updated 2007/ 0101 15:58:25 (31
Finish

Figure 12-5
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Voltages

After selecting multiple servers and Voltages settings, you will see the display as shown in Figure 12-6.
Clicking the Query tab will allow IPMI View to collect the voltage readings from the selected servers. The
information listed in the table shows the voltage status of the selected servers.

;j IPMI ¥iew ¥2.6.20 (build 070927) - Super Micro Computer, Inc.

File Edit Session Manage Help
O & Ode 2
S C . j Group Management
UPERMI R‘ Fan Temperatu.re|vohﬁge |Sensors Event Log | ACPI | Power || LAN Config | FRU | Text Conmle | General Info
IPMI Domain =~ & + § £ &
E 10 L [l
192.168.10.240 Valtage
S 58.10. 241 System Name | IP Sensor Name Reading Tnit Low Limit High Limit
= iggiggiggﬁ 192.168.10241  [192.168.10341  [CPUI Veore 122 Volts 108 161
5] 192.168.10. 10216610241 |192168.10241 (P2 Veors no Volts 108 161
10216610241 [102.166.10241 5.3V L] Tolts 796 363
1021668.10241 |192168.10241 |57 501 Volts 445 5 40
10216610241 |192.168.10241 127 1161 Tolts 1075 1324
102168.10241 |192.168.10241 L12V 26 Volts 132 108
10216610241 [102.168.10241 [1.57 147 Tolts 134 164
102168.10241 [192.168.10241 S5VEB 475 Volts 445 5 40
10216610241 [192.166.10241 [VBAT 54 Tolts 796 363
10216610131 |192168.10.131 [CPUT Veore 1.36 Volts 108 161
10216610131 |192.166.10.131  [oPU2 Veoore 0o Tolts 108 161
10216810131 |192.168.10131 .3V ] Volts 296 363
10216610131 |192.1668.10.131 |57 441 Tolts 445 5 40
10216810131 |192.168.10.131 [12¥ 1132 Volts 1075 1324
10216610131 |192.168.10131  [V&E 436 Tolts 445 5 40
10216810131 |192.168.10131 |VBAT 315 Volts 296 363
Groups & e
IPMI Domain (5/5)
Pl seconis Tast updated 2007/10401 15:59:27 (16)
Finish
Figure 12-6
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Sensors

After selecting multiple servers and clicking the Sensors tab, you will see the window as shown in Figure
12-7. Click the Query button for IPMI View to collect the sensor readings from the selected servers. The
information listed in the table shows the sensor status of the selected servers. The window here shows

the chassis status and power supply status. If the chassis is opened or a power supply has failed, the
reading will be in red.

17 IPMI View ¥2.6.29 (build 070927) - Super Micro Computer, Inc. FEK

File Edit Session Manage Help
BE & Bde 2
SUPERMICR@ % 2 Mansoemen
Fan | Temperatire Voliage| Sensors | Event Log | ACPI | Power | LAN Config | FRU | Text Console | Generel Info
SaEERT
Power Suppy and Introsion
i Sstemn Name P Sensor Name Statuz
E\ ggigg}ggﬁ 192.168.10.241 192.168.10.241 [vtrsion Chassiz OK
T 192.168.10.241 192.168.10.241 Power Supply Power Supply OK
192.168.10.131 192.168.10.131 [vtrsion IChassiz Opened |
192.168.10.131 192.168.10.131 Power Supply Power Supply OK
Gruups B&da
[] Refiesh every s last updated :2007/10/01 15:59:32 (43
Finish

Figure 12-7
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Event log

After selecting multiple servers and clicking the Event Log tab, you will see a display as shown in Figure
12-8. Click the Query button for IPMI View to collect the event logs from the selected servers. The table
below displays the event log of the selected servers. Select the Host combo box to filter the event log

data in the table.

:j IPMI ¥iew ¥2.6.20 (build 070927) - Super Micro Computer, Inc.

File Edit Session Manage Help

OiEa gl 2 e

j Group Management

SUPERM ICR‘. Fan| Temperature | Voltage Sensors| EventLog | ACPI| Power| LAN Config | FRU | Text Console | General Info
IPMI Domain =~ & + § £ & m E
SEL
= tattleiel 1 SystemName:|A]l v
=] 197.168.10.242
[51 192 168.10.243 Svstern Name i3 Time Stamp Type Sensor | Event Type
192.168.10.241 192.168.10.241 08/10/2007 14:22:00 Fri Phosical... | Intrusion |De-assertion: Physical Security (Chassis Int A
102.168.10.241 102.168.10.241 08/10/2007 14:24:02 Fri Fan Fanb Assertion: Lower Non-critical - going low —
192.168.10.241 102.168.10.241 08/10/2007 14:24:.02 Fri Fan Fan’ Assertion: Lower Critical - going low
102.168.10.241 102.168.10.241 08/10/2007 14:24:02 Fri Fan Fanb Assertion: Lower Non-recoverable - going
192.168.10.241 102.168.10.241 08/10/2007 14:24:.02 Fri Fan Fan?/C... |Assertion: Lower Non-critical - going low
102.168.10.241 102.168.10.241 08/10/2007 14:24:02 Fri Fan Fan7/C... |Assertion: Lower Critical - going low
192.168.10.241 192.168.10.241 08/10/2007 14:24:02 Fri Fan Fan7iC. .. |Assertion: Lower Non-recoverable - going
102.168.10.241 102.168.10.241 08/10/2007 14:24:02 Fri Fan Power ... |Assertion: Lower Non-critical - going low
192.168.10.241 102.168.10.241 08/10/2007 14:24:.02 Fri Fan Power ... |Assertion: Lower Critical - going low
192.168.10.241 192.168.10.241 08/10/2007 14:24:02 Fri Fan Power 8. |Asertion: Lower Non-recoverable - going
192.168.10.241 102.168.10.241 08/10/2007 14:24:.02 Fri Fan CPUO... |Assertion: Lower Non-critical - going low
102.168.10.241 102.168.10.241 08/10/2007 14:24:02 Fri Fan CPU O |Assertion: Lower Critical - going low
192.168.10.241 102.168.10.241 08/10/2007 14:24:.02 Fri Fan CPUO... [Assertion: Lower Non-recoverable - going
102.168.10.241 102.168.10.241 08/10/2007 14:24:02 Fri Fan Therma... |[Amertion: Lower Non-critical - going low
192.168.10.241 102.168.10.241 08/10/2007 14:24:.02 Fri Fan Therma... |Asertion: Lower Critical - going low
192.168.10.241 192.168.10.241 08/10/2007 14:24:02 Fri Fan Therma... |Azertion: Lower Non-recoverable - going
Groups & g | [192.168.10.241 102.168.10.241 08/10/2007 14:24:.02 Fri Fan Therma... |[Amertion: Lower Non-critical - going low
TPMI Damain (55) 102.168.10.241 102.168.10.241 08/10/2007 14:24:02 Fri Fan Therma... |Asertion: Lower Critical - going low
192.168.10.241 192.168.10.241 08/10/2007 14:24:02 Fri Fan Therma... [Lssmrtion: Lower Non-recoverable - going
102.168.10.241 102.168.10.241 08/10/2007 14:34:34 Fri Fan Fanb Assertion: Lower Non-critical - going low
192.168.10.241 102.168.10.241 08/10/2007 14:34:34 Fri Fan Fan’ Assertion: Lower Critical - going low
102.168.10.241 102.168.10.241 08/10/2007 14:34:34 Fri Fan Fanb Assertion: Lower Non-recoverable - going
< | ¥
[] Refiesh every s last updated :2007/10/01 16:01:48 (895)
Finish

Figure 12-8
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ACPI

After selecting multiple servers and clicking the ACPI tab, you will see a display as shown in Figure 12-9.
Click the Query button for IPMI View to collect the ACPI state from the selected servers. The table
displays the ACPI state of the selected servers.

Lj IPMI ¥iew ¥2.6.20 (build 070927) - Super Micro Computer, Inc.

File Edit Session Manage Help

BE a0l R e

(=1

j Group Management

SUPERMICR‘. Fan | Temperatore | Yoltage | Sensmrs EventLog|ﬁCPI |P0wer LAN Config | FRU | Text Consmle | General Info
SIETIE-S i
AP
System Name P ACPI 3tate | Description | On/Off
] 192 168 10.243 192.168.10241  |192.168.10.241 ‘snmn working
192168.10131  [192163.10.131  [0/G0 warking
25| Groups B&de
i IPMI Domain {5/5)
[ Eehed ey secands last updated 2007/10/01 16:02:05 (2)
Finish
Figure 12-9
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Power

After selecting multiple servers and clicking the Power tab, you will see a display as shown in Figure 12-
10. Click one of the Power Control buttons to send a command to the selected server. The text area will

show the result.

(=1

;j IPMI ¥iew ¥2.6.20 (build 070927) - Super Micro Computer, Inc.

File Edit Session Manage Help

BEa Gdee R
j Group Management

SUPERMICR‘. Fan | Temperatore | Voltage | Sensors || Event Log ACPI| P0W9T|LANC0nﬁg FRU || Text Conmle | General Info

Creaceful Power Control

i} IPMI Domain =~ & + § £ &
E‘H iéi:gig;ié Soft shutdownivia ACP) | [ Graceful Shutdown | [ Graceful Reboot | [ Graceful Power Cycle
Chassiz Power Control
[ Power Down ] [ Power Up ] [ Power Cyele ] [ Rest
Result

[2007/10/01 16:02:42] Sending Power Up to 192.165.10.241... OK
[2007/10/01 16:02:42] Sending Power Up to 192.165.10.243... OK

Groups & e

U8 [F}T Domain (5/5)

Finish
Figure 12-10

Supermicro IPMI View User’s Guide



LAN Configuration

After selecting a single server and clicking the LAN Config tab, you will see a display as shown in Figure
12-11. Click Query to get the information needed from a single server and copy it to other servers for
data-sharing. The text area will show the results of the query and provide updates. The Clear button is
used to clear the text field only; it will not clear the actual LAN configuration from the server.

:: IPMI Yiew ¥2.6.29 (build 070927) - Super Micro Computer, Inc.

File Edit Sesdon Manage Help

hEagEe R e

j Group Management

SUPERM ICR‘. Fan || Temperature | Yoltage | Sensors| EventLog || ACPI | Power | LAN Config | FRTT || Text Console | Greneral Info
il IPMI Domain A - Q £ 4 | LAN Confizguration
Cratewray [P: 192.168.10.254 (ret ]
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= 192.168.10.243 ST Bt
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Result

[2007/10/01 16:03:11] Getting LAN Configration from 192.1658.10.241... OK
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Subnet Mask = 255.255.255.0

[2007 /10/01 16:03:12] Getting SNMP Configration from 192.168.10.241... OK
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25l Groups E & & g | [SNMP Destination 2= 0.0.0.0 ( 00:00:00:00:00:00 )
UM [P} Diomain (5/5) SMNMP Destination 3 = 0.0.0.0 { 00:00:00:00:00:00 )
Finizh

Figure 12-11
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FRU

After selecting a single server and clicking the FRU tab, you will see a display as shown in Figure 12-12.
Click the Query button for IPMI View to get the FRU information from a single server, and copy it to
other servers for data-sharing. The text area will show the results of a query and provide updates. The
Clear button is used to clear the text field only; it will not clear the actual FRU data from the server.

:j IPMI Yiew ¥2.6.29 (build 070927) - Super Micro Computer, Inc.

File Edit Sesdon Manage Help

hEagoe e

j Group Management
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[ oet |[ Update || Clear |
Board Info Product Info
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[2007/10/01 16:03:41] Getting FRU from 152.168.10.241... 0K

=5 Groups B&a o
Wl TFRI Domain (550

Figure 12-12
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Text Console

After selecting a single server and clicking the Text Console tab, you will see a display as shown in Figure

12-13. Click the Open button for IPMI View to create an internal text console window for the selected

server. Click Start to start the text console redirection. The power control buttons displayed on the

status bar provides power on, power off and reset commands, allowing you to easily power on or power

off a remote server. The Encode checkbox is for RMCP+ encoding. Check it to enable packet encoding

between the IPMI View and a server.

:j IPMI Yiew ¥2.6.29 (build 070927) - Super Micro Computer, Inc.
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Figure 12-13
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General Information

After selecting multiple servers and clicking the General Info tab, you will see a display as shown in
Figure 12-14. Select the fields you want to query from the servers, and click the Query button to allow
IPMI View to collect the information from the selected servers.
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192.168.10.241 192.168.10.241 20 RMCP+ 0125 2.0
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13 Trap Receiver

The Trap Receiver is a utility used for receiving traps from the BMC. In the event of a sensor error or a
sensor reading that exceeds a threshold, the BMC will send SNMP traps to the destinations set in the
BMC. The Trap Receiver is executed on the destination site and receives the SNMP trap from multiple
senders (BMCs). If you select a category, you can see all the traps in that category. Furthermore, when
you click a trap in the trap list, you can see its details in the Trap Structure window. Please refer to the
BMC Setting page in IPMI View to set the SNMP destination.

As shown in Figure 12-1, there are several components to the IPMI Trap Receiver.

* Menu Bar: contains pull-down menus for exiting the programs, getting help, etc.
* Tool Bar: contains all IPMI Trap Receiver features.

* Category: categorizes the traps by the sender, community and sensor.

* Trap Structure: It is a tree structure that displays traps in detail.

* Status Bar: shows messages regarding the current status of related components.

* Trap List: shows detailed information for traps received.

o IPMI Trap Receiver Y20 (huild 051122) - Soper Micio Computer, Toc

Menu Bar—Fis Eip
[
Toolbar —f— » @ a i 9
art Stop  Save  Load  Clear  Emai
Category All |
i 1 ] _ovwer Non.criical - going low )
L] an 2 82IBEA0M5  pokdic Fand owver Critical - golng low 2005A 0001 15:24:38
L J192.16810.245 3 192168190245 [puklic FANA _ovwer Non recoversble - going low | 200500001 15:24:40 ..,
# 15216810247 a 192166.10245  |puklic FAN3 over Non-crilical - going low 2005410001 152441 ...
Category — 5 19216610245 kb FANS |ower Criteal- oo ow 20051001 15:24:43 ..
6 19216810245 [pukc FAN3 —0wver Non-recoversile - going low | 2005410401 15:24:44 ...
7 19216010245 [pukc FaN2 —ower Non-critical - poing low 2005A0001 15:46:10 ...
Sender | Commurity | Sensor 8 19216810245 [pklic FAN 2 ovwver Critical - going low 20054001 154811 .
—_— 5 13216010245  |pukhc FAN 2 _ower Nonrecaversbie - going bow | 2005A 0001 154613
Trap Structure 10 19216810245  |pukthc cPUA _pper Mon-critical - gong high 2005000 15:46:22 ..
| S0P Trap Alm 19216810245  |pukiic CPU1 —pper Mon-criical - 2005510007 15:46:25 ...
= ] SNWP Header nz 192NEBA0245 pukic CPU1 pper Citical - gong bagh 2005010007 1546226 ...
& Mezzags Lenghy 125 M3 19216810245  |pudic CPUA _pper Monrecoverable - gong high (20050001 15:46:26 ., __ Tr’ap List
& Message Versior v1 4 19216810245 [puiklic FAN3 _owver Non-critica - going low 200540001 1545325 ..,
& Communiy. pubbc 15 19216810245 [puklic FAN3 ower Critical - golg low 2005A 0001 154526 ..,
= _]PDU Header 16 19216810245 [pukic FAN3 _ower Non-recoversble - going low | 200540001 15:4526
& Type: Trap 17 19216510245 puic Fan4 _ovver hNor-crilical - going los 2005410401 154329
Tra p Structure —§— & lengh 109 ha :197 16810245 :[ll’l‘ Fand avier Critical - ol inwe O05A 0T 1545 31
@ Enderprize; 136141180 na 19216810245  puklic FAaN 4 _ovver Non-recoversiie - going bowe (2005A 0001 1549032 ..
® Agent P: 19216510.245 20 19216810245  |puenc CPU _pper Mon-criical - 20050000 154299
@ Generic Trap Tvpec 6 121 19216810245 [puikic icPU1 pper Citical - gong high 2005410001 154250 .,
& Specific Trao Troe: 262400 (22 19216810245 [pukic icrU pper Mon-recoverable - going high | 200540001 15:4%50 .,
& Tmelicks | 1128180277 (23 19216010245 [pekhc FAN2 _ower Nor-critical - going low 200540401 15:50:07 .
= ] PDU Body (24 19216810245 |pukic FAN2 —owver Critical - going low 2005A10/01 15:50:08 ...
@ Total Length of Varisbie Bir 25 19216810245 |priklic FaNZ _uwver Nonerecuoversble - gung kow 200510001 1550010 ...
= [ |Bnd 26 19216810245  putic FAN 4 _ovver Non.crlical - gong low 200500401 155022 ..,
® Length ot Emding 70 | [27 (19216810245 [pukc FANG | ower Critical - coing low Zo0sAon 155075 | |
4 > Sender = 192162.10.245 | Cominuridy = * | Sensor = *
Status Bar —|airan received Serder IP=132163.10.247, cortert = | CPU1 JUper Non-recaverab - going igh

Figure 12-1
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Tool Bar functions

The tool bar provides the following features as shown in Figure 12-2.

> @ B a o oS

Stop Save Load Clear Etriil

Figure 12-2

*  Start: starts the Trap Receiver.

* Stop: stops the Trap Receiver.

* Save: saves the traps received into a file.

* Load: loads a saved trap file into the Trap Receiver.

* Clear: clears all the traps in the trap list.

* Email: displays an “Email-Alert Settings” dialog box (see Figure 12-3). Fill the “SMTP server”, “From
(email address)” and “To (email address)” fields. The “From” and “To” addresses must be valid in the
SMTP server. If the SMTP server requires authentication, please enter the username and password.
Once entering needed information, click the Test button to verify if your email works properly.

Email Alert 3

Email Alert Setting

] Enable Email Alert

SMTP Server: | |

Frarr: | |

Ta: | |

[] Authertication

Uzername: | |

Password: | |

(S | |

[ ok ] [ cancel

Figure 12-3
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Category

There are three categories including: Sender, Community and Sensor as shown in Figure 12-4. The
Sender page lists all sender IP addresses. The Community page lists all SNMP communities. The Sensor
page lists all sensor types from the traps. Clicking on each category type will act as a filter for all traps in
the traps list. Click the All button to cancel all filters.

Category All Category All
] g
& 19216510245 # public

& 192165810247

Sender | Community | Sensor Sender | Community | SENSOF

Category All
=1
# FAN4
Fapr 3
Fap 2
CPL
Fard 1
FApr &
FAr B
Far 7
FAr &
Irtrusion

288888888

Sender | Commnunty | Sensor

Figure 12-4

Once a category has been selected, the filter condition will be displayed at the bottom of the “trap” list.
See Figure 12-5 for reference. As displayed in Figure 12-5, the filter is “Sender = 192.168.10.245,
Community = public, Sensor = CPU 1”. The trap list displays only those traps whose contents are
included in each of the three filters.
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Mum Sender Community Sensar Description LocalTimeStamp

10 192.165.10.245  |public CPUA Lpper Mon-critical - going high | 20050 0001 139:46:22..
11 192.165.10.245  |public CPUA Lpper Mon-critical - going high | 20050 0701 13:46:25..
12 192.165.10.245  |public CPUA Upper Critical - going high 200301 0001 15:46:26...
13 192.165.10.245  |public CPUA Lpper Mon-recoverable - goi... (20050 0/01 13:46:26..
20 192.165.10.245  |public CPUA Lpper Mon-critical - going high | 20050 0/01 13:49:49..
21 192.165.10.245  |public CPUA Upper Critical - going high 200301 001 15:49:30...
22 192.165.10.245  |public CPUA Lpper Mon-recoverable - goi... (20050 0/01 13:49:30...

Sender = 192.165.10.245 | Community = public | Sensar = CPL 1

Trap Structure

The Trap Structure displays detailed information for the selected item in the trap list. Information

Figure 12-5

includes the “SNMP Header”, “PDU Header”, “PDU Body”, “Bind” and “PET” data.

Trap Structure

| ] SMMP Trap
= ] SHMP Header

# Message Length: 125
# Meszage Version: vl
& Community: public

LR B B B B K

= [ ] POU Header

Type: Trap

length: 109

Enterprise: 1.36.1.4.1.3183.1.1
Agent 1P 19216310245
Generic Trap Type: B

Specific Trap Type: 262400
Timeticks ; 1128180281

= ] POU Body

# Total Length of Yariable Binding: 72
= | Eind
# Length of Binding: 70
& CIC:1361.41.3185114
[= | PET Data
# [FAM 3] Lower Mon-critical - going low
& " [E0=E]" @k 2= TF]" @28 x0x 0= 0x

Figure 12-6
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Receiving a Trap

When the Trap Receiver receives a trap from the BMC, an alert bar will display on the screen for about
10 seconds to notify you that a trap has occurred. In addition, an email alert will be sent according to the

information field in the Email Alert dialog box. Please refer to Figure 12-7.

The email will include the following information.

A SNMP trap received

Sender:192.168.10.247

Sensor:FAN 2

Description:Lower Non-recoverable - going low
Time:2005/11/22 14:27:07 Tue

#F IPMI Trap Beceiver ¥2.0 (bnild 051122) - Super Micro Compnter, Inc_

File Help
> @ @ a o =
Stop Save Load Clear Etniil
Category a1 Purn Sendet CatnraLIrity Sensor Description LaocalTimeStamp
J 192.165.10.... [public Lowwer Critical - gaing low
# 192165102435 192.165.10.... [public Fan 4 Lovwer Mon-recoverable - goi.. (2005010001 15:24:4,.,
& 19216510247 192.165.10.... [public FAM 3 Lowver Mon-critical - going low 20050 0J01 15:24:4 .
AOAATTAR et S e Seitisnb g oy 2005010001 15:24:4..
ATrap Received rable - goi... 200510401 15:24:4
Sender: 192.168.10.247 - gning low [2005A 0001 15:46:1...
ﬂl Communy || Sensor Content: [ FAN 2] Lower Critical - going low ng lovw . 2005 0M0 15461
table - goi... (200500001 15:46:1..
Trap Structure T T92 TG, 10, [P RO URREr MUF-CIUCET - going high | 20050 0401 15:46:2...
;| SHMP Trap A1 192.165.10.... [public: CPL1 Upper Mon-critical - going high | 200501 0J01 15:46:2..
= _| ShP Header 12 192.165.10.... [public P Upper Critical - going high 20050 001 15:46:2..,
# Message Length: 125 13 192.165.10.... [public CPU 1 Upper Mon-recaverable - goin... (200510001 15:46:2...
# Message Yersion: i 14 192.165.10.... [public Fapn 3 Lowver Mon-critical - going loww (200501 0J01 15:49:2.
# Community; public 15 192.165.10.... [public FAM 3 Lavver Critical - gaing law 20051 0001 15:48:2.
= _| POU Header 16 192.165.10.... [public Fapn 3 Lovwer Mon-recoverable - goi.. (2005010001 15:49:2...
# Type: Trap 17 19216810, |public FAn 4 Lavver Mon-critical - going low (20054 0401 15:48:2.
# length: 109 15 192.165.10.... [public Fan 4 Lowver Critical - going law 20050 001 15:49:3..,
# Erterprize: 13614131 19 192.1653.10.... [public Fap 4 Lovver Mon-recoverable - goi... |20054 001 15:49:3.
# Agent P 19216810245 20 192.165.10.... [public CPU 1 Upper Mon-critical - gaing high {20051 0001 15:45:4...
# Generic Trap Type: 6 21 192.168.10.... [public CPU Upper Critical - going high 20051 0J01 15:49:5.
# Specific Trap Type: 262¢ 22 192.165.10.... [public: CPL1 Upper Mon-recoverable - goin... 20054 0001 15:49:5..
# Timeticks : 1128180277 23 192.168.10.... [public Fan 2 Lowver Mon-critical - going low 200501 0001 1:5:50:0...
= _| PDU Body 24 192.165.10.... [public Fan 2 Lowwer Critical - gaing low 200501 D01 15:50:0...
? Tatal Length of Yariable K 25 192.165.10.... [public Fap 2 Lowver Mon-recoverable - goi.. (200500001 15:50:1..
£ ﬁl e > h Sender = * | Commmunity =* | Sensor = *
A Trap Received: Sender [P =192.165.10.247 cortent = [ FAN 2 Lower Critical - going low Sending Email ...

Figure 12-7
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Appendix A: SIM Firmware Update

1. Select a remote system on the System list and click File> Update IPMI Firmware to start the
firmware update.

Edit Sessinn  Manage
Hewe ... ]
Dizcover [PMI Device
Eeload Configuration
Save Configuration
pdate TP Firniweare

Bt

Figure A-1

2. Click the Open button to select the firmware you desire and then click Start to continue.

;j Dpdate Firmware @

TP: 192.168.10.249

Firrrevare File: | | ’ Open ” Start ]

Message:

Figure A-2
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3. Alogin dialog will appear. Please enter the Login_ID and the password. This user will be granted the
privilege as an Administrator.

Please input ID and Password E|

Login ID ADMIN

* Administrator level is reguired

Canrel

Figure A-3

4. A firmware information dialog will appear. It shows detailed information on the current and new
firmware. Click Yes to continue.

Request Confirmation E|

Curresnt firmware

@ Firmware Version: 1.5.0 build 4238
Firmware Tag: fug-14-06-17-30
hendware [D: 0x22
CEM: peppercon

Mew firmoware:

Firmnware Version: 1.5.2 build 4238

Firmwaze Tag: Aug-16-06-11-10

Firmware Size: 3092376 botes

Firmware Path: C:fw-kira-kimsmigd-smid c-peppercon_040200-4238-081606-1-5-2 bin

Would wou like fo continue ?

Figure A-4

5. The firmware file will start to upload. This process may take few minutes to complete.

IP: 192.168.10.249

srcon_040200-4235-081606-1-5-2 bin |

Firrmuvare File:

Uploading firmwears

Message:

Login to 192.168_10_249
tart firmware upgarde

Mploading firmware ..

Figure A-5
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6. Please wait for the firmware to upload. Once uploading is completed, the BMC will start to flash the
firmware internally. This step may take about a minute. Please try to connect to the system after
two minutes.
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Appendix B: SIM(W) KVM Console and Virtual
Media

SIM(W) KVM Console allows the user to perform console redirection via KVM (Keyboard/Video/Mouse)
support as shown in Figure B-1.

lj IPMI Yiew ¥2.7.13 (build 100504) - Super Micro Computer, Inc.
File Edit 3ession Manage Help

Tl e Oh & 2 ®
SUPERMICR. ] El19z168.12.160

@ @ O Fusersen [T] Vistuel Mot [A] Soft Keyboard t1ps PP Menn
IPMI Domain 2 + 9 £t &
192.168.12.171 3 13 12 1 Fanl 675.00 RPM
%172:31.2'.18'4 14 13 i Fan2 0.00 RPM
= 172,31 143 15 14 i Fan3 0.00 RPH
:

&) 172.31.1 431 16 1? PS Status 0K [66 CO 00 001

1 1

o 172.31.2.123
17231.2.145
% 172312146 C:N>type aa
o 172.31.162 SDR ID i Sensor
Tl 172.31.2.31
Tl 172.31.2.58
Tl 172.31.2.59
| 172.31.262
Tl 172.31.2.081
= 192.168.10.118
21192.168.1099
& 192.168.10.30
& 192.165.10.50

190 91010

C:n>ipmicfg —-sdr >aa

Sensor Reading

CPUZ Temp nsa [G0 EO 07 001
3ystem Temp 36.00 degree C
CPU1 Vcore A2V

CPUZ Vcore .00

+120 .31

+3.3U .23

DIMM .81

+5U .06

.23

.23

.00

.00

@8 RPM

-

UBAT
Fanl
Fan2
Fan3 .
PS5 Status 0K [00 CO 00 00]

o
=J
[cR-NLENRTNE, RN -

i
2
3
4
5
6
?
[:]
9
16 +3.3USB
11
12
13
14
17

Redirection Viewerstarted..

Login || Event Log | Sensors | IPM Device | BMC Setting || Users | Text Console | KM Consols

RMCP+ Open Session successful

Figure B-1 SIM(W) KVM Console Main Screen
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SIM(W) Console Toolbar

The SIM(W) Console Toolbar provides seven tool buttons which will allow the user to perform the
following actions as shown in Figure B-2.

Start Video Redirection
Stop Video Redirection
Screenshot
Refresh (the page)

Full Screen (display)
|

@g Q Full Screen [ Virtual Media Soft K|eyhoard 1tps [ Menu
f |

Soft Keyboard (to use the soft keyboard)
Virtual Media (to use Virtual Media)

Menu

Figure B-2 SIM(W) KVM Console Toolbar

I} Start Video Redirection:

Click this button to start SIM(W) KVM console redirection.

@ Stop Video Redirection:

Click this button to stop video redirection. Please note that the drive redirection will continue to work
when it is enabled.

Q Full Screen:

Click this button to maximize the size of the remote video screen displayed on the local computer screen
as shown in Figure B-3.

Figure B-3 Full Screen
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[ |
Virtual Media:

Click this button to enable Virtual Media support as shown in Figure B-4.

“4 Virtual Media X]

Browss ’ Connect Floppy ]

FloppwTT3E EKew Media

CD Media
@ 150 Image [ Biowse ] [ ComnectCDDVD

OEF
OF
Statos

Target Drive Connected To Read Bytes

Virtual Flappy Mot connected nfa
Virtual CD Mot conmnected '

Clos=

Figure B-4 Virtual Media

*  Floppy/USB key Media: This feature allows the user to redirect Floppy/USB Media.

* CD Media: This feature allows the user to redirect CD/DVD or ISO image file.

* Connect Floppy: Click this button to start to redirect your Floppy Image or USB Key Media.
* Connect CD/DVD: Click this button to start to redirect your CD/DVD or ISO image file.
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LY Soft Keyboard:

Click this button to use the Soft Keyboard for console redirection as shown in Figure B-5.

Combination (of Keys) Lock (Hold Modifier Key)

Soft Keyboard v(0 .96

Langnage Modifier Kew(Ctd, Alt, Shift, Win, |PrtSc)
lEng]ishl[Ummd States) v ‘ | & Combination| []Lock
(O Single Key

EEd Fi |F2 |F3 |F4 | F5 |F6 |F? |F8 | F9 |F10|F11|F12 Prn ScrI.Paul
1 |2 24 s IE 7 18 [9 |D | = BS Ins |Hon PUpl Nun! [* |-
Ta o /] & A | ol 11 1 o R T [l ] Del [End PD)'I Hon & |PUp
Capiil =l <l d. ol ol ol Tl Jeoul 1l -l * + “ e (4
Shift 2z el A T v . | Shift it End| § |PDin
Chl | WinlAl sillmillagicall ol ol

Figure B-5 Soft Keyboard

* Language: This feature allows you to select a proper language setting for your soft keyboard.
* Combination: Check this button if you want to use a combinations of modifier keys

* Single Key: Check this button if you want to use a modifier key as single key.

* Lock: Check this button to hold the modifier key you’ve clicked.

The menu is same as web KVM UL.
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Appendix C: SIM(WA) iKVM Console and
Virtual Media

Click Launch KVM Console to open SIM(WA) iKVM Window as in Figure C-1.

:: IPMI ¥iew ¥2.7.13 (build 100504) - Super Micto Computer, Inc_

File Edit Sesmion Manage Help

WY IESIETEEI)

5o @

SUPERMICR® |

IPMI Domain =~ & ¥ Q@ £ %
Y

=) 172.31.2.114
211723111321
=) 182.168.10.174
=) 202.126.183.134
) 192 168.10.168
211723119
—1172.31.1.36
=,
28l Groups G & e
1| IPMI Domain

=5 New Groupl (201070
Wew Group2 (207)
s (04T

----- =5, New Grroupd (3220

o 192.168.12.168 = 192.168.12.125

Console Redivection

B Press the button to lawnch the redirection console and manage the server remotely.

Lannch KW Console

Login | Event Log | Bensors | [PM Device | BMC Betting || Users | Tewt Console || EVM Comanle ]

EMCP+ Open Session suecessful

Figure C-1 SIM(WA) iKVM Window
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Please note that SIM(WA) iKVM window supports same features as other versions of Web KVM as
shown in Figure C-2.

Java iKYM Yiewer v1.55 17 [192.168.12.125] - Resolution 652 X 492 - FPS 0
Virtual Media  Record  Playback  Macro  Options  UserList  Exit

Press any key to enter the menu

Booting CentDS (Z.6.18-164.e15) in 3 seconds...[J]

Figure C-2 iKVM Window
Virtual Media (USB Floppy & Flash)

Click Virtual Media on the menu bar and then click Virtual Storage to display the Virtual Media (USB
Floppy & Flash screen) as shown in Figure C-3.

B Virtual Media 1.2 12

{ USE FloppyéeFlash:| CDROM&IS0
Setting for Device 1
Logical Dirive Twpe Image Filename and Full Path
|N0 Select - | | |
B R T

Connection Status History

|
W

Figure C-3 Virtual Media (USB Floppy & Flash)
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Logical Drive Type: From the pull-down menu select the logical drive type.

Image Filename and Full Path: Enter the image file name and the full path to the file. It is available
only for ISO files.

Refresh: Click this button to refresh the page.

Plug In: Click this button to mount your logical drive as virtual media.

Plug Out: Click this button to un-mount virtual media.

OK: Click this button to confirm and exit.

Connection Status History: This window displays the connection and the status of virtual media.

Virtual Media (CDROM & ISO)
Click CDROM & ISO to display the Virtual Media (CDROM & 1SO) as shown in Figure C-4.

Yirtual Media 1.2 12

USE Floppy&Flash |
Setting for Device 2
Logical Drive Type Image Filename and Full Path
Mo Zelect “
R ] [

Connection Status History

Figure C-4 Virtual Media (CDROM & ISO)

Logical Drive Type: From the pull-down menu select the logical drive type.

Image Filename and Full Path: Enter the image file name and the full path to the ISO file.
Refresh: Click this button to refresh the page.

Plug In: Click this button to mount your logical drive as virtual media.

Plug Out: Click this button to un-mount virtual media.

OK: Click this button to confirm and exit.

Connection Status History: This window displays the connection and the status of Virtual Media.
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iKVM Virtual Keyboard

Virtual Keyboard provides soft keyboard support and allows the user to click a key on the soft keyboard
by using the mouse when a keyboard is not available. Refer to Figure C-5 for Virtual Keyboard.

Englizh keyboard

L 213|456 |T|B |90 )- =] ~— |jims|" |2 (k| |*]-
M lg|wle|r |t |y|u|ifo|p|[]] | \idel| | F ] T2 N
Jllals|d|{f|g|hk k ] - - — |
T lz|x|ec|v|b|n|m]|, / als T S LT
ctrl [&¢| alt it |2 8] e ||| +[=)|[ s fel]

Figure C-5 Virtual Keyboard
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Appendix D: SIM(W) Firmware Update

1. To re-flash SIM(W) Firmware, please select an SIM(W) device and then Update firmware in the
menu. A dialog box appears.

Confirmation

- | ) Thiz 1= BIM (W device. Please make sure won have correct firmware for vpdate (% 1ma)

O] [ cancel

Figure D-1 SIM(W) Firmware Re-flash

2. Make sure that you've selected the correct firmware for update, and click OK.This dialog box
appears.

¥ AFTFlazh rs_<|
Remote Flash Tool for Hermomn/AaM FUW T121
IF: |192.168.12.169 | Optinmns
[ ] Preserve Bootloader
File: | | [ Buowss. .. ]
[ ] Preserve Config Module
Flash

Figure D-2 YAFU Flash
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3. After you've selected a firmware file for remote flashing, it will be checked if it is a valid file before
remote flashing starts.

¥ AFTFlash &|
Remote Flash Tool for Hermon/AM FUW T121
IF: |192.158.12.169 | Options
[ ] Preserve BootLoadex

File: |D:'-.FW'-.P.MI'-.K?DCT-L_13EI.hm| | Brows. |

[] Preserve Confiz Maodule
Mew fiomware version : 1.30

Figure D-3 YAFU Flash

e |P: This item displays the IP Address of the IPMI device.

* Browse: Enter the file name or browse the data base to select a file that you want to perform
remote flashing.

* Preserve BootLoader: Check this box to preserve the settings of BootLoader.

* Preserve Config Module: Check this box to preserve the settings of Configuration Module.

* Firmware Version: The new firmware version will be displayed.

* Flash: Click <Flash> to commit the file for remote flashing.

4. Click FW Version. Remote Flashing can only be performed by an Administrator. If you are an
administrator, enter your ID and your password in the screen below. Then click OK.

Please input ID) and Password [g|
9} LoginlD | |
\-‘:‘/ Pazzwrord | |
* A dministrator level s required,

| ok || Comel |

Figure D-4 ID and Password (Administrator)
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5. Once you’ve checked the firmware versions an
figures below.

Y AFTFlazh

Remote Flash Tool for Hermon/AM FUW

d clicked Flash, firmware flashing will start. See the

X

V121

IF: |192.158.12.169

Ciptions

[ ] Preserve BootLoadex

File: |D:'-.FW'-.P.MI".K?DCT-L_13EI.ima

| [ Browss... ]

Mew fiomware version : 1.30

Current firmesare versomn: 1,30

[] Preserve Confiz Maodule

¢ FW Version |

Figure D-5 Display of Current Firmware Version

Y AFIFlazh

Remote Flash Tool for Hermomn/AM FUW

File: |D AFWARDETDCT-L_1230 4ma |

IF: |192.168.12.169

Wew finmeware version ; 1.30

Current fimmware verson: 1,30

atatus: 79 (1,310,720 byes £ 16,777,216 bares )

3

V121

Ciptions
Prezerve Bootl.oader

Browss. .
Preserve Config Module

FI Werson

Femaining Time: 6 minfs) 47 mels)

Figure D-6 Remote Flash #1
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Y AFUFlash E|
Remote Flash Tool for Hermon/ANM FW w121
IF: |192.158.12.159 | Options

Presrve BootLoader

File: |D:\FW\AMI\K?DCT—L_130.M| Bitowss...

Preserve Confiz Module
Wew firmsare wersion : 1.30
Crremt firmeare version: 1.30 FW Version
Status: 22% ( 3,801,088 bores # 16,777,216 bortes )
LA L]
Remaining Time: 5 minfz) 41 seciE) Flash

Figure D-7 Remote Flash Screen #2

YAFUFlash b_(|
Remote Flash Tool for Hermon/AM FW V121
IF: |192.168.12.159 | Optinns

Presrve Bootl.oader

File: |D:\FW\AMI\K?DCT-L_13EI.:’.ma| Birowse...

Preserve Config Modulz
Wew tirmuare wersion : 1.30
Crurrent firmeware verson: 1.30 FW ¥ersion
Status: 519 (8,585,216 bytes £ 16,777,216 bytes )
CCLLEC LR L L L L LT
Remadning Time: 3 minlz) 35 soiz) Flash

Figure D-8 Remote Flash Screen #3

6. When the flashing is complete, the status field displays “Finished.” Click Close to exit this dialog box.

Y AFTTFlazh &|
Remote Flash Tool for Hermon/AM FW w121
IF: |192.168.12.169 | Oiptions

Preserve Bootloader

File: |D:\FW\AMI‘\}{?DCT-L_13EI.ﬁm| Browse...

Preserve Config Moduole
Wew firmueare wersion - 1.30

Crurent firmorare verson: 1.30 FW Verson

Status: Findshed . (BMC needs 1 minute to restart)

IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIlllllllllllllllllllllq

Figure D-9 Remote Flash Screen #4
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Appendix E: SIM(WA) Firmware Update

1. Select an SIM(WA) device and select <Update Firmware> in the menu for SIM(WA) Firmware re-
flashing. A dialog box appears.

Confirmation

. | ) This iz STM (W A) device. Please make sure you have correct firmyeare for update (* bin)

oKk ][ Comcel |

Figure E-1 Firmware Update

2. Make sure that you have the correct firmware for update, and click OK. The dialog box below

appears.
Flazh Tool [g|
Remote Flash Tool for Hermon/AT FW ¥1.20
I 19216812125 |
File: | | Browse...
Flazh

Figure E-2 Flash

3. Click Browse to select the desired firmware file for remote flashing. It will be checked to see if it is a
valid file before remote flashing starts.

Flash Tool g'

Remote Flash Tool for Hermon/AT FW

IF: |192.168.12.125 |

Fil: |[D:FW\ATENEEDIL 817 bin N:

Hew firmuware version : 01.15

Figure E-3 Flash
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4. Click FW Version. Remote flashing can only be performed by an administrator. If you are an
administrator, enter your ID and password in the dialog box.

Flease input ID and Paseword &|

2) wen
R

* Ldyndnistrator level iz reguined

| ok || Cancel |

Figure E-4 ID/Password

5. Once you’ve checked the firmware versions and clicked Flash, firmware flashing will start.

Flash Tool &l

Remaote Flash Tool for Hermon/AT FW ¥1.20

IF: |192.153.12_125 |

File: |D:\FW\ATEI-I\X8DTL_81?.hm | B

Blew firmware wersion - 01.15

Current finmare version: 01.10

Figure E-5 Firmware Versions

Flash Tool

)

Remote Flash Tool for Hermon/AT FW Y120

IF: |192.1r53.12.125 |

File: |D:\FW\ATEI-I\XBDTL_81?.hm | Browss,

Mews fimmware verson ; 01.15

Current firmware version: 01,10 FW Version

Statuz Uploading. ..

Figure E-6 Remote Flash #1
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Flazh Tool

X)

Remote Flash Tool for Hermon/AT FW ¥1.2.0

IF: |192.168.12.125 |

File: |D:\FW\ATEN'\X8DTL_81?.bin | Browss ..

Wew firmware version - 01.15

Current firmyware version: 01.10 FW Version

Status: Updating. ..

- T

Figure E-7 Remote Flash #2

Flash Tool

X)

Remote Flash Tool for Hermon/AT FW ¥1z0

IF: |192_158_12.125 |

File: |D:\FW\ATEN\X8DTL_81?.bm | Browse. .

Wew firmware version - 01.15

Current firmvware version: 01.10 FW Version

Status: Updating. .

Figure E-8 Remote Flash #3
6. When the flashing is complete, the status field displays “Finished”. Click Close to exit this dialog box.

Flash Tool |1>_(|

Remote Flash Tool for Hermon/AT FWW F1.20

IF: |192.153.12.125 |

File: |D:'\FW\ATEN'\X8DTL_81?.bin | Browse...

Wew firmuware version : 01.15

Current firmweare version: 01.10 FW Version

Statos: Finished

Figure E-9 Remote Flash #4
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Appendix F: ASPEED X10 Firmware Update

1. Select an ASPEED BMC device and select Update Firmware in the menu for ASPEED Firmware Re-
flashing. The dialog box below appears.

Confirmation &J
ey
'.0_‘ This is ASPEED BMC. Please make sure you have correct firmware for update (* bin,32M size)

Cancel

Figure F-1 Firmware Update

2. Make sure that you have the correct firmware for the update, and click OK. The dialog box below
appears.

Flash Tool &J

Remote Flash Tool for Hermon ASPEEDIAT FW ¥1.30

P 101321770

Status: Preserve Config

Figure F-2 Flash

3. Click Browse to select the desired firmware file for remote flashing. It will be checked to see if it is a
valid file before remote flashing starts.

Flash Tool l&]

Remote Flash Tool for Hermon ASPEEDIAT FW ¥1.:0

P 101321770

File: |(CASMT_X10_105 bin

Wew finmuare version : 1.5

Statos: Preserve Config

Figure F-3 Flash
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4. Click FW Version. Remote flashing can only be performed by an administrator. If you are an

administrator, enter your ID and password in the dialog box.

.
Please input ID and Password

o

LoginID ADMIN

Password [ 1111 ]
* A dmindstrator level is required

[ ok ][ cancel |

Figure F-4 ID/Password

5. Once you’ve checked the firmware versions and click Flash, firmware flashing will start.

Flash Tool

Remote Flash Tool for Hermon ASPEEDIAT FW

IP: 110.132177.0

File: (C/8MT_X10_105 bin
New finmware verson : 1.5
Curent firmware version: 01.04

Status:

Figure F-5 Firmware Versions

6. When the flashing is complete, the status field displays “Done. (BMC needs 1 minute to restart.)”.

Click Close to exit this dialog box.

[ Flash Tool &Jw
Remote Flash Tool for Hermon, ASPEED/AT FW ¥1.30
I 101331770
File: |CA3MT_H10_105bin Browse...
New finmware version : 1.5
Current firmware version: 01.04 FW Version
Status: Done. (BMC needs 1 minute to restart) Preserve Config

Figure F-6 Remote Flash
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Contacting Supermicro

Headquarters

Address: Super Micro Computer, Inc.
980 Rock Ave.
San Jose, CA 95131 U.S.A.

Tel: +1 (408) 503-8000

Fax: +1 (408) 503-8008

Email: marketing@supermicro.com (General Information)
support@supermicro.com (Technical Support)

Web Site: Www.supermicro.com

Europe

Address: Super Micro Computer B.V.

Het Sterrenbeeld 28, 5215 ML
's-Hertogenbosch, The Netherlands

Tel: +31 (0) 73-6400390
Fax: +31(0) 73-6416525
Email: sales@supermicro.nl (General Information)

support@supermicro.nl (Technical Support)
rma@supermicro.nl (Customer Support)

Web Site: www.supermicro.com.nl
Asia-Pacific
Address: Super Micro Computer, Inc.

3F, No. 150, Jian 1st Rd.
Zhonghe Dist., New Taipei City 235
Taiwan (R.0.C)

Tel: +886-(2) 8226-3990

Fax: +886-(2) 8226-3992

Email: support@supermicro.com.tw
Web Site: www.supermicro.com.tw
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