Debian 11 installation with DMAR DRHD handling fault status reg 3 error message
When installing Debian 11 on systems with a MegaRAID 9341-4i RAID controller, it may come to error messages such as AVAGO EFI SAS Driver is Unhealthy' during the starting process and DMAR: DRHD: handling fault status reg 3 when starting the operating system. In this article, we show how to install Debian 11 by using the kernel parameters intel_iommu=on and iommu=pt.
Error message in the BIOS, during boot process and installation
In this case, the installation was performed on a Supermicro mainboard X11SCH-LN4F and on a MegaRAID 9341-4i RAID controller, as both of these components lead to this error message in combination. This case is described in detail in the following article: MegaRAID 9341-4i Debian 11 DMAR DRHD handling fault status reg 3
Three types of errors that occur
-
Error message of the controller in the postscreen - AVAGO EFI SAS Driver is unhealthy
-
Error message encountered when booting from the boot medium DMAR: DRHD: handling fault status reg 3
-
Error in the Debian installer during hard drive selection: the RAID is not displayed
Solution
To solve the problem, the Intel IOMMU functions must be set to pass-through in the Linux kernel.
The following kernel parameters must be set for this:intel_iommu=on iommu=pt
These parameters must be set three times
- in the Debian installer
- after booting in the GRUB
- in the OS under /etc/default/grub
1) Changes made during installation using the Debian installer
For a UEFi installation
-
With "E" for Edit Selection, the boot entry can be changed
-
Here, the third line must be edited "linux /install.amd/vmlinuz vga=788 --- quiet"
-
"--- quiet" must be replaced by "intel_iommu=on iommu=pt"
For a LEGACY installation
-
In legacy mode, the boot entry can be edited via tab-key
-
edit "linux /install.amd/vmlinuz vga=788 --- quiet"
-
"--- quiet" must be replaced by "intel_iommu=on iommu=pt"
The Raid is now displayed
-
The Raid is now displayed and can be selected for the installation
2) Changes after installation in the GRUB
-
After installation, edit the boot entry via "E"
-
The third-to-last line linux /boot/vmlinuz-5-10.0-17...... ro quiet must be edited.
-
"quiet" must be replaced by "intel_iommu=on iommu=pt"
3) Changes in OS
-
Navigate to the /etc/default directory
-
Edit grub with, for example, nano
-
GRUB_CMBLINE_LINUX_DEFAULT="intel_iommu=on iommu=pt"
-
Update GRUB using"su -" and "update-grub"
After the parameters have been set and the update-grub command has been performed, they will now be executed every time the system starts up, ensuring that the RAID controller and the RAID array are detected correctly.
More information
- (SOLVED) "kernel: DMAR: DRHD: handling fault status reg 3" (bbs.archlinux.org, 29.09.2017)
- raid controller 9341-8i (forum.proxmox.com, 04.05.2021)
- How to assign devices with VT-d in KVM (www.linux-kvm.org 25.6.2016)
- Setting up KVM with GPU passthrough in Debian Buster (gist.github.com 13.08.2020)
References
- A Tour Beyond BIOS: Using IOMMU for DMA Protection in UEFI Firmware (www.intel.com)
- Linux IOMMU Support (www.kernel.org/doc)
|
Author: Leo Dirr Leo Dirr joined Thomas-Krenn in 2018 to work in technical support. At the moment Leo is specializing in Windows Server, Software-Defined technologies and networking.
|
|
Translator: Alina Ranzinger Alina has been working at Thomas-Krenn.AG since 2024. After her training as multilingual business assistant, she got her job as assistant of the Product Management and is responsible for the translation of texts and for the organisation of the department.
|

